summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorLucas Rocha <lucasr@gnome.org>2006-03-23 03:43:23 +0000
committerLucas Almeida Rocha <lucasr@src.gnome.org>2006-03-23 03:43:23 +0000
commite919741e641a82d7eb99dd5f0463c7006024c474 (patch)
treed1aeddc4ee98e0e3c16c0bb5d8bcc944d2d106aa /configure.in
parent168e2625b937d1acfc1f1d8dab82b4bb838053bf (diff)
Implement the "message" command on notification icon with libnotify
2006-03-22 Lucas Rocha <lucasr@gnome.org> Implement the "message" command on notification icon with libnotify bubbles. Patch from Davyd Madeley <davyd@madeley.id.au>. * configure.in: add libnotify checking. * src/notification.c (zenity_notification_handle_stdin, zenity_notification): initialize libnotify and implement "message" command.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in14
1 files changed, 14 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 51f8121..ca4f214 100644
--- a/configure.in
+++ b/configure.in
@@ -67,6 +67,20 @@ dnl *******************************
AC_PATH_PROG(PERL,perl,)
dnl *******************************
+dnl libnotify check
+dnl *******************************
+PKG_CHECK_MODULES(LIBNOTIFY, libnotify >= 0.3.2,
+ HAVE_LIBNOTIFY="yes", HAVE_LIBNOTIFY="no")
+if test "x$HAVE_LIBNOTIFY" = "xyes"; then
+ ZENITY_CFLAGS="$ZENITY_CFLAGS $LIBNOTIFY_CFLAGS"
+ ZENITY_LIBS="$ZENITY_LIBS $LIBNOTIFY_LIBS"
+
+ AC_SUBST(ZENITY_CFLAGS)
+ AC_SUBST(ZENITY_LIBS)
+ AC_DEFINE(HAVE_LIBNOTIFY, 1, [libnotify is available on this machine])
+fi
+
+dnl *******************************
dnl Internationalization
dnl *******************************