summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorGlynn Foster <glynn.foster@sun.com>2004-07-18 23:37:06 +0000
committerGlynn Foster <gman@src.gnome.org>2004-07-18 23:37:06 +0000
commite6290c86ffbb3c29a2bb071744ab7e425327dc27 (patch)
treeed75cc4138e5bd1a4010625716ab5a41d4783ac8 /configure.in
parent7a71be6387c47b6160ea4e7f289bec1ec2111fd4 (diff)
Fix up compilation using Forte compiler. Based on patch from Ivan Noris.
2004-07-19 Glynn Foster <glynn.foster@sun.com> * configure.in, src/Makefile.am: Fix up compilation using Forte compiler. Based on patch from Ivan Noris. Fixes #143041.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in34
1 files changed, 34 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 5e6d950..11c9012 100644
--- a/configure.in
+++ b/configure.in
@@ -26,6 +26,40 @@ if test x$SCROLLKEEPER_CONFIG = xno; then
AC_MSG_ERROR(Couldn't find scrollkeeper-config. Please install the scrollkeeper package)
fi
+dnl ***********************************************
+dnl X development libraries check
+dnl ***********************************************
+
+#
+# If Pango included the shared library dependencies from X11 in
+# the pkg-config output, then we use that (to avoid duplicates).
+# but if they were omitted to avoid binary compatibility problems
+# then we need to repeat the checks.
+#
+if $PKG_CONFIG --exists pangoxft ; then
+ PANGO_PACKAGES="pangox pangoxft"
+else
+ PANGO_PACKAGES="pangox"
+fi
+
+x_libs="`$PKG_CONFIG --libs $PANGO_PACKAGES`"
+case x_libs in
+ *-lX11*) pango_omitted_x_deps=no ;;
+ *) pango_omitted_x_deps=yes ;;
+esac
+
+if test $pango_omitted_x_deps = yes ; then
+ AC_PATH_XTRA
+
+ if test x$no_x = xyes ; then
+ AC_MSG_ERROR([X development libraries not found])
+ else
+ X_LIBS="$X_PRE_LIBS $X_LIBS -lX11 $X_EXTRA_LIBS"
+ fi
+fi
+
+AC_SUBST(X_LIBS)
+
dnl *******************************
dnl perl check
dnl *******************************