summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorArx Cruz <arxcruz@src.gnome.org>2011-07-19 14:33:28 -0300
committerArx Cruz <arxcruz@src.gnome.org>2011-07-19 14:39:05 -0300
commit1d339e29a782de8962379652635c9ee42988d99c (patch)
treee371539ef66a0403fc78147180d160c923c441bb /configure.ac
parent239fc66928c41ffd0ebaa88cfcd05ff114028895 (diff)
Enable html support in --text-info option. This fix bug #598655, thanks for the work from Francis Meyvis francis.meyvis at gmail dot com. Two new options in --text-info: * --html - enable HTML support. * --url - load an url
If you need to load a local html file, you can use --filename=patch/to/html. Examples: * zenity --text-info --html --filename=file.html * zenity --text-info --html --url=www.gnome.org Zenity will add http:// if isn't declared in --url
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac22
1 files changed, 22 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index db01bf7..84e2c36 100644
--- a/configure.ac
+++ b/configure.ac
@@ -77,6 +77,28 @@ if test x$enable_libnotify = xyes; then
fi
# *******************************
+# webkit check
+# *******************************
+
+WEBKITGTK_REQUIRED=1.4.0
+
+AC_ARG_ENABLE([webkitgtk],
+ [AS_HELP_STRING([--enable-webkitgtk],
+ [Enable webkit support])],
+ [],
+ [enable_webkitgtk=yes])
+
+if test x$enable_webkitgtk = xyes; then
+ PKG_CHECK_MODULES([WEBKIT], [webkitgtk-3.0 >= $WEBKITGTK_REQUIRED],
+ [HAVE_WEBKITGTK="yes"],[HAVE_WEBKITGTK="no"])
+ AC_SUBST([WEBKIT_CFLAGS])
+ AC_SUBST([WEBKIT_LIBS])
+ if test "x$HAVE_WEBKITGTK" = "xyes"; then
+ AC_DEFINE([HAVE_WEBKITGTK], [1], [webkitgtk is available on this machine])
+ fi
+fi
+
+# *******************************
# Debug
# *******************************