summaryrefslogtreecommitdiff
path: root/libdhcp/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'libdhcp/CMakeLists.txt')
-rw-r--r--libdhcp/CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/libdhcp/CMakeLists.txt b/libdhcp/CMakeLists.txt
new file mode 100644
index 0000000..e525191
--- /dev/null
+++ b/libdhcp/CMakeLists.txt
@@ -0,0 +1,13 @@
+# libdhcp/CMakeLists.txt - TODO
+#
+# Copyright (C) 2024 Luke T. Shumaker <lukeshu@lukeshu.com>
+# SPDX-Licence-Identifier: AGPL-3.0-or-later
+
+add_library(libdhcp INTERFACE)
+target_include_directories(libdhcp SYSTEM INTERFACE ${CMAKE_CURRENT_SOURCE_DIR}/include)
+target_sources(libdhcp INTERFACE
+ dhcp.c
+)
+target_link_libraries(libdhcp INTERFACE
+ libmisc
+)