summaryrefslogtreecommitdiff
path: root/libcr_ipc/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'libcr_ipc/CMakeLists.txt')
-rw-r--r--libcr_ipc/CMakeLists.txt12
1 files changed, 8 insertions, 4 deletions
diff --git a/libcr_ipc/CMakeLists.txt b/libcr_ipc/CMakeLists.txt
index 8545798..60d3f2d 100644
--- a/libcr_ipc/CMakeLists.txt
+++ b/libcr_ipc/CMakeLists.txt
@@ -7,18 +7,22 @@ add_library(libcr_ipc INTERFACE)
target_include_directories(libcr_ipc PUBLIC INTERFACE ${CMAKE_CURRENT_LIST_DIR}/include)
target_sources(libcr_ipc INTERFACE
chan.c
- select.c
+ mutex.c
+ rpc.c
+ rwmutex.c
+ sema.c
)
target_link_libraries(libcr_ipc INTERFACE
libcr
+ libmisc
)
set(ipc_tests
chan
- #select
- #mutex
- #owned_mutex
+ mutex
rpc
+ rwmutex
+ select
sema
)
foreach(test IN LISTS ipc_tests)