summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 10 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 356e3e9..df13977 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -80,7 +80,16 @@ function(add_stack_analysis arg_outfile arg_objlib_target)
OUTPUT "${arg_outfile}"
COMMAND "${CMAKE_SOURCE_DIR}/build-aux/stack.c.gen" "${PICO_PLATFORM}" "${CMAKE_SOURCE_DIR}" "$<TARGET_OBJECTS:${arg_objlib_target}>" >"${arg_outfile}"
COMMAND_EXPAND_LISTS
- DEPENDS "$<TARGET_OBJECTS:${arg_objlib_target}>" "${CMAKE_SOURCE_DIR}/build-aux/stack.c.gen" "${CMAKE_SOURCE_DIR}/build-aux/measurestack/__init__.py"
+ DEPENDS "$<TARGET_OBJECTS:${arg_objlib_target}>"
+ "${CMAKE_SOURCE_DIR}/build-aux/stack.c.gen"
+ "${CMAKE_SOURCE_DIR}/build-aux/measurestack/__init__.py"
+ "${CMAKE_SOURCE_DIR}/build-aux/measurestack/analyze.py"
+ "${CMAKE_SOURCE_DIR}/build-aux/measurestack/app_main.py"
+ "${CMAKE_SOURCE_DIR}/build-aux/measurestack/app_output.py"
+ "${CMAKE_SOURCE_DIR}/build-aux/measurestack/app_plugins.py"
+ "${CMAKE_SOURCE_DIR}/build-aux/measurestack/test_analyze.py"
+ "${CMAKE_SOURCE_DIR}/build-aux/measurestack/util.py"
+ "${CMAKE_SOURCE_DIR}/build-aux/measurestack/vcg.py"
COMMENT "Calculating ${arg_objlib_target} required stack sizes"
)
endfunction()