summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt43
1 files changed, 13 insertions, 30 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b379a8f..22756c1 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -14,6 +14,8 @@ include("${PICO_SDK_PATH}/external/pico_sdk_import.cmake")
project(sbc_harness)
+add_subdirectory(3rd-party/pico-fmt/pico_fmt)
+add_subdirectory(3rd-party/pico-fmt/pico_printf)
pico_sdk_init()
if ((PICO_PLATFORM STREQUAL "host") AND (NOT PICO_NO_GC_SECTIONS))
@@ -80,7 +82,16 @@ function(add_stack_analysis arg_outfile arg_objlib_target)
OUTPUT "${arg_outfile}"
COMMAND "${CMAKE_SOURCE_DIR}/build-aux/stack.c.gen" "${PICO_PLATFORM}" "${CMAKE_SOURCE_DIR}" "$<TARGET_OBJECTS:${arg_objlib_target}>" >"${arg_outfile}"
COMMAND_EXPAND_LISTS
- DEPENDS "$<TARGET_OBJECTS:${arg_objlib_target}>" "${CMAKE_SOURCE_DIR}/build-aux/stack.c.gen"
+ DEPENDS "$<TARGET_OBJECTS:${arg_objlib_target}>"
+ "${CMAKE_SOURCE_DIR}/build-aux/stack.c.gen"
+ "${CMAKE_SOURCE_DIR}/build-aux/measurestack/__init__.py"
+ "${CMAKE_SOURCE_DIR}/build-aux/measurestack/analyze.py"
+ "${CMAKE_SOURCE_DIR}/build-aux/measurestack/app_main.py"
+ "${CMAKE_SOURCE_DIR}/build-aux/measurestack/app_output.py"
+ "${CMAKE_SOURCE_DIR}/build-aux/measurestack/app_plugins.py"
+ "${CMAKE_SOURCE_DIR}/build-aux/measurestack/test_analyze.py"
+ "${CMAKE_SOURCE_DIR}/build-aux/measurestack/util.py"
+ "${CMAKE_SOURCE_DIR}/build-aux/measurestack/vcg.py"
COMMENT "Calculating ${arg_objlib_target} required stack sizes"
)
endfunction()
@@ -106,37 +117,9 @@ function(add_lib_test arg_libname arg_testname)
endif()
endfunction()
-function(_apply_matrix_helper _m_depth _m_assignments)
- list(LENGTH _m_arg_matrix _m_dimensions)
- math(EXPR _m_dimensions ${_m_dimensions}/2)
- if("${_m_depth}" EQUAL "${_m_dimensions}")
- cmake_language(CALL "${_m_arg_action}" "${_m_n}" "${_m_assignments}")
- math(EXPR _m_n "${_m_n}+1")
- set(_m_n "${_m_n}" PARENT_SCOPE)
- else()
- math(EXPR _m_ik "${_m_depth}*2")
- list(GET _m_arg_matrix "${_m_ik}" _m_tmp_key)
-
- math(EXPR _m_iv "${_m_ik}+1")
- list(GET _m_arg_matrix "${_m_iv}" _m_tmp_vals)
- string(REGEX REPLACE "^\\[(.*)\\]$" "\\1" _m_tmp_vals "${_m_tmp_vals}")
-
- foreach(_m_tmp_val IN LISTS _m_tmp_vals)
- math(EXPR _m_tmp_depth "${_m_depth}+1")
- set(_m_tmp_assignments "${_m_assignments}")
- list(APPEND _m_tmp_assignments "${_m_tmp_key}=${_m_tmp_val}")
- _apply_matrix_helper("${_m_tmp_depth}" "${_m_tmp_assignments}")
- set(_m_n "${_m_n}" PARENT_SCOPE)
- endforeach()
- endif()
-endfunction()
-function(apply_matrix _m_arg_action _m_arg_matrix)
- set(_m_n 0)
- _apply_matrix_helper(0 "")
-endfunction()
-
add_subdirectory(libmisc)
add_subdirectory(libobj)
+add_subdirectory(libfmt)
add_subdirectory(libcr)
add_subdirectory(libcr_ipc)
add_subdirectory(libhw_generic)