summaryrefslogtreecommitdiff
path: root/libobj/CMakeLists.txt
diff options
context:
space:
mode:
authorLuke T. Shumaker <lukeshu@lukeshu.com>2025-02-10 00:06:34 -0700
committerLuke T. Shumaker <lukeshu@lukeshu.com>2025-02-10 00:06:34 -0700
commit6cd125e1ffd44fdf62c44d22c519561a8c9d7268 (patch)
treebf2b4a8225fe0d6f00084a1577c70bb564a20600 /libobj/CMakeLists.txt
parentf466cff948ec638f26a9a77a391904ebe03c4dfb (diff)
parenta51875001eb672d73c9d84d44bb32abce327b931 (diff)
Merge branch 'lukeshu/libobj-simple'
Diffstat (limited to 'libobj/CMakeLists.txt')
-rw-r--r--libobj/CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/libobj/CMakeLists.txt b/libobj/CMakeLists.txt
new file mode 100644
index 0000000..1cc552c
--- /dev/null
+++ b/libobj/CMakeLists.txt
@@ -0,0 +1,14 @@
+# libobj/CMakeLists.txt - A simple Go-ish object system built on GCC -fplan9-extensions
+#
+# Copyright (C) 2024-2025 Luke T. Shumaker <lukeshu@lukeshu.com>
+# SPDX-License-Identifier: AGPL-3.0-or-later
+
+add_library(libobj INTERFACE)
+target_include_directories(libobj SYSTEM INTERFACE ${CMAKE_CURRENT_SOURCE_DIR}/include)
+target_link_libraries(libobj INTERFACE
+ libmisc
+)
+target_compile_options(libobj INTERFACE "$<$<COMPILE_LANGUAGE:C>:-fplan9-extensions>")
+
+add_lib_test(libobj test_obj)
+add_lib_test(libobj test_nest)