summaryrefslogtreecommitdiff
path: root/libhw/CMakeLists.txt
diff options
context:
space:
mode:
authorLuke T. Shumaker <lukeshu@lukeshu.com>2024-11-15 11:58:59 -0700
committerLuke T. Shumaker <lukeshu@lukeshu.com>2024-11-19 20:15:16 -0700
commit936fd0145896acbf55de496f036af55a01b80e82 (patch)
treea81cfff1fe552a184d614e7a0639583f0a8f8252 /libhw/CMakeLists.txt
parent573b0f7d4d4a7e84ae8d1e4a7c0611dd9f513fa2 (diff)
libhw_generic: Split into a separate library
Diffstat (limited to 'libhw/CMakeLists.txt')
-rw-r--r--libhw/CMakeLists.txt14
1 files changed, 5 insertions, 9 deletions
diff --git a/libhw/CMakeLists.txt b/libhw/CMakeLists.txt
index 3627641..d1767da 100644
--- a/libhw/CMakeLists.txt
+++ b/libhw/CMakeLists.txt
@@ -1,22 +1,18 @@
-# libhw/CMakeLists.txt - TODO
+# libhw/CMakeLists.txt - Device drivers
#
# Copyright (C) 2024 Luke T. Shumaker <lukeshu@lukeshu.com>
# SPDX-License-Identifier: AGPL-3.0-or-later
add_library(libhw INTERFACE)
-target_include_directories(libhw SYSTEM INTERFACE ${CMAKE_CURRENT_SOURCE_DIR}/common_include)
target_link_libraries(libhw INTERFACE
- libcr
- libcr_ipc
- libmisc
-)
-
-target_sources(libhw INTERFACE
- common_alarmclock.c
+ libhw_generic
)
if (PICO_PLATFORM STREQUAL "rp2040")
target_include_directories(libhw SYSTEM INTERFACE ${CMAKE_CURRENT_SOURCE_DIR}/rp2040_include)
+ target_link_libraries(libhw INTERFACE
+ libcr_ipc
+ )
target_sources(libhw INTERFACE
rp2040_hwtimer.c
rp2040_hwspi.c