summaryrefslogtreecommitdiff
path: root/libcr_ipc/CMakeLists.txt
diff options
context:
space:
mode:
authorLuke T. Shumaker <lukeshu@lukeshu.com>2025-04-07 20:29:35 -0600
committerLuke T. Shumaker <lukeshu@lukeshu.com>2025-04-07 20:29:35 -0600
commitd053a0f6dffc575611324b81acaef0d1554bda6c (patch)
tree3eb702a06625ef1f6be0648f7fec311b628808e9 /libcr_ipc/CMakeLists.txt
parent33b7cf675238367db2fc0528dea103d7792eaa0e (diff)
parent062e063f76c5937be4dc8465f6471ff9b5eb7be9 (diff)
Merge branch 'lukeshu/ipc'
Diffstat (limited to 'libcr_ipc/CMakeLists.txt')
-rw-r--r--libcr_ipc/CMakeLists.txt13
1 files changed, 9 insertions, 4 deletions
diff --git a/libcr_ipc/CMakeLists.txt b/libcr_ipc/CMakeLists.txt
index 8545798..bd72f54 100644
--- a/libcr_ipc/CMakeLists.txt
+++ b/libcr_ipc/CMakeLists.txt
@@ -6,19 +6,24 @@
add_library(libcr_ipc INTERFACE)
target_include_directories(libcr_ipc PUBLIC INTERFACE ${CMAKE_CURRENT_LIST_DIR}/include)
target_sources(libcr_ipc INTERFACE
+ _linkedlist.c
chan.c
- select.c
+ mutex.c
+ rpc.c
+ rwmutex.c
+ sema.c
)
target_link_libraries(libcr_ipc INTERFACE
libcr
+ libmisc
)
set(ipc_tests
chan
- #select
- #mutex
- #owned_mutex
+ mutex
rpc
+ rwmutex
+ select
sema
)
foreach(test IN LISTS ipc_tests)