summaryrefslogtreecommitdiff
path: root/libcr_ipc/CMakeLists.txt
diff options
context:
space:
mode:
authorLuke T. Shumaker <lukeshu@lukeshu.com>2024-11-25 08:28:13 -0700
committerLuke T. Shumaker <lukeshu@lukeshu.com>2024-11-26 20:23:53 -0700
commit88f2b88c3889e9dd0c894d389d67b17617412094 (patch)
tree2b0f8535735f7eee56cd7ac5abb1d169c9d5e252 /libcr_ipc/CMakeLists.txt
parenta8dc3fc4ad08c159243271c403848d23261aa699 (diff)
wip: libcr_ipc: Add some tests
Diffstat (limited to 'libcr_ipc/CMakeLists.txt')
-rw-r--r--libcr_ipc/CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/libcr_ipc/CMakeLists.txt b/libcr_ipc/CMakeLists.txt
index d44203e..2a1c747 100644
--- a/libcr_ipc/CMakeLists.txt
+++ b/libcr_ipc/CMakeLists.txt
@@ -8,3 +8,17 @@ target_include_directories(libcr_ipc SYSTEM INTERFACE ${CMAKE_CURRENT_LIST_DIR}/
target_link_libraries(libcr_ipc INTERFACE
libcr
)
+
+set(ipc_tests
+ chan
+ #select
+ #mutex
+ #rpc
+ #sema
+)
+if (ENABLE_TESTS)
+ foreach(test IN LISTS ipc_tests)
+ add_lib_test(libcr_ipc "test_${test}")
+ target_include_directories("test_${test}" PUBLIC ${CMAKE_CURRENT_SOURCE_DIR}/tests)
+ endforeach()
+endif()