summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorLuke T. Shumaker <lukeshu@lukeshu.com>2024-09-14 10:04:38 -0600
committerLuke T. Shumaker <lukeshu@lukeshu.com>2024-09-14 10:04:38 -0600
commitd297d8ec1f5bac1015c53dfe169d2ce1a838b007 (patch)
tree53bea6122b91c7cabc1ee174493c57f860715e92 /CMakeLists.txt
parenta302a66f47f4c7e8cbfe131650d84ca3e6cadea3 (diff)
more
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 5 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3334714..ad5fba9 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -9,6 +9,9 @@ pico_sdk_init()
add_executable(hello_world hello_world.c)
target_link_libraries(hello_world pico_stdlib)
-# create map/bin/hex/uf2 file in addition to ELF.
-pico_add_extra_outputs(hello_world)
+pico_enable_stdio_usb(hello_world 1)
+pico_enable_stdio_uart(hello_world 0)
+pico_enable_stdio_semihosting(hello_world 0)
+pico_enable_stdio_rtt(hello_world 0)
+pico_add_extra_outputs(hello_world) # create map/bin/hex/uf2 file in addition to ELF.
pico_set_program_url(hello_world "https://git.lukeshu.com/sbc-harness")