summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorLuke T. Shumaker <lukeshu@lukeshu.com>2024-11-25 14:38:17 -0700
committerLuke T. Shumaker <lukeshu@lukeshu.com>2024-11-25 14:40:06 -0700
commitcce21287a154dea92ae9005aebe8c0b650faa173 (patch)
tree2de4580a9b7409be4b6ffeee4b6c93738c164081 /CMakeLists.txt
parent92de40d33e085040e4b9936ae1ddebf152dff102 (diff)
Drop ubsan, it makes gdb difficult
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 0 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4082d53..698ce0f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -17,10 +17,6 @@ project(sbc_harness)
pico_sdk_init()
add_compile_options(-Wall -Wextra -Wswitch-enum -Werror)
-if (PICO_PLATFORM STREQUAL "host")
- add_compile_options(-fsanitize=undefined)
- add_link_options(-fsanitize=undefined)
-endif()
function(_suppress_tinyusb_warnings)
__suppress_tinyusb_warnings()