summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorLuke T. Shumaker <lukeshu@lukeshu.com>2024-09-27 17:38:00 -0600
committerLuke T. Shumaker <lukeshu@lukeshu.com>2024-09-27 17:38:00 -0600
commitb1fc106b5294d162415ff715c6dece11945efdb2 (patch)
tree8ff16e13b987e5b8a4cac6f8ceabf35c9a046a94 /CMakeLists.txt
parente5e15c04bc58c34906e6d7cfcbad68d1a5617563 (diff)
wip
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 6 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 73c6b8f..7f16070 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -12,9 +12,7 @@ project(sbc_harness)
pico_sdk_init()
-add_custom_target(generate
- COMMENT Create generated files that are included in the source distribution
-)
+define_property(TARGET PROPERTY "GENERATED_SOURCES")
add_subdirectory(libcr)
add_subdirectory(libcr_ipc)
@@ -24,3 +22,8 @@ add_subdirectory(lib9p)
add_subdirectory(cmd/sbc_harness)
add_subdirectory(cmd/srv9p)
+
+add_custom_target(generate
+ COMMENT Create generated files that are included in the source distribution
+ DEPENDS
+)