summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 9 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index f1cd957..4ded3ef 100644
--- a/configure.ac
+++ b/configure.ac
@@ -24,6 +24,11 @@ if test "x$HAVE_GIT" = x ; then
AC_MSG_ERROR([Please install the 'git' utility])
fi
+AC_CHECK_PROG(HAVE_WGET,WGET,yes)
+if test "x$HAVE_WGET" = x ; then
+ AC_MSG_ERROR([Please install the 'wget' utility])
+fi
+
dnl 'sh' does not nescessarily imply 'bash'
AC_CHECK_PROG(HAVE_BASH,bash,yes)
if test "x$HAVE_BASH" = x ; then
@@ -66,9 +71,10 @@ AC_MSG_RESULT([yes])
dnl This is at least needed by memtest
AC_LANG_PUSH([C])
-AC_MSG_NOTICE([----------------------------------------------------------------])
-AC_MSG_NOTICE([The next few tests are for 32-bit C, NOT the native architecture])
-AC_MSG_NOTICE([----------------------------------------------------------------])
+AC_MSG_NOTICE([----------------------------------------------------------------------------])
+AC_MSG_NOTICE([The next few tests are for 32-bit C, NOT necessarily the native architecture])
+AC_MSG_NOTICE([----------------------------------------------------------------------------])
+AC_MSG_NOTICE([If you have GCC, but these fail, look for a 'gcc-multilib' package])
CFLAGS='-march=i486 -m32'
AC_CHECK_HEADERS([stdint.h sys/io.h],,[AC_MSG_ERROR([Could not find libc headers])])
AC_LANG_POP([C])