summaryrefslogtreecommitdiff
path: root/libhw_generic/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'libhw_generic/CMakeLists.txt')
-rw-r--r--libhw_generic/CMakeLists.txt15
1 files changed, 15 insertions, 0 deletions
diff --git a/libhw_generic/CMakeLists.txt b/libhw_generic/CMakeLists.txt
new file mode 100644
index 0000000..9c88937
--- /dev/null
+++ b/libhw_generic/CMakeLists.txt
@@ -0,0 +1,15 @@
+# libhw_generic/CMakeLists.txt - UAPI device interfaces
+#
+# Copyright (C) 2024 Luke T. Shumaker <lukeshu@lukeshu.com>
+# SPDX-License-Identifier: AGPL-3.0-or-later
+
+add_library(libhw_generic INTERFACE)
+target_include_directories(libhw_generic SYSTEM INTERFACE ${CMAKE_CURRENT_SOURCE_DIR}/include)
+target_link_libraries(libhw_generic INTERFACE
+ libmisc
+ libcr
+)
+
+target_sources(libhw_generic INTERFACE
+ alarmclock.c
+)