summaryrefslogtreecommitdiff
path: root/libhw/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'libhw/CMakeLists.txt')
-rw-r--r--libhw/CMakeLists.txt38
1 files changed, 0 insertions, 38 deletions
diff --git a/libhw/CMakeLists.txt b/libhw/CMakeLists.txt
deleted file mode 100644
index 242a3fa..0000000
--- a/libhw/CMakeLists.txt
+++ /dev/null
@@ -1,38 +0,0 @@
-# libhw/CMakeLists.txt - Device drivers
-#
-# Copyright (C) 2024-2025 Luke T. Shumaker <lukeshu@lukeshu.com>
-# SPDX-License-Identifier: AGPL-3.0-or-later
-
-add_library(libhw INTERFACE)
-target_link_libraries(libhw INTERFACE
- libhw_generic
-)
-
-if (PICO_PLATFORM STREQUAL "rp2040")
- target_include_directories(libhw SYSTEM INTERFACE ${CMAKE_CURRENT_SOURCE_DIR}/rp2040_include)
- target_link_libraries(libhw INTERFACE
- libcr_ipc
- )
- target_sources(libhw INTERFACE
- rp2040_dma.c
- rp2040_gpioirq.c
- rp2040_hwspi.c
- rp2040_hwtimer.c
- w5500.c
- )
- target_link_libraries(libhw INTERFACE
- hardware_gpio
- hardware_irq
- hardware_spi
- hardware_timer
- )
-endif()
-
-if (PICO_PLATFORM STREQUAL "host")
- target_include_directories(libhw SYSTEM INTERFACE ${CMAKE_CURRENT_SOURCE_DIR}/host_include)
- target_sources(libhw INTERFACE
- host_util.c
- host_alarmclock.c
- host_net.c
- )
-endif()