summaryrefslogtreecommitdiff
path: root/libcr_ipc/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'libcr_ipc/CMakeLists.txt')
-rw-r--r--libcr_ipc/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/libcr_ipc/CMakeLists.txt b/libcr_ipc/CMakeLists.txt
index 7d249d7..bd72f54 100644
--- a/libcr_ipc/CMakeLists.txt
+++ b/libcr_ipc/CMakeLists.txt
@@ -10,6 +10,7 @@ target_sources(libcr_ipc INTERFACE
chan.c
mutex.c
rpc.c
+ rwmutex.c
sema.c
)
target_link_libraries(libcr_ipc INTERFACE
@@ -21,6 +22,7 @@ set(ipc_tests
chan
mutex
rpc
+ rwmutex
select
sema
)