summaryrefslogtreecommitdiff
path: root/cmd/srv9p/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'cmd/srv9p/CMakeLists.txt')
-rw-r--r--cmd/srv9p/CMakeLists.txt15
1 files changed, 15 insertions, 0 deletions
diff --git a/cmd/srv9p/CMakeLists.txt b/cmd/srv9p/CMakeLists.txt
new file mode 100644
index 0000000..3db8795
--- /dev/null
+++ b/cmd/srv9p/CMakeLists.txt
@@ -0,0 +1,15 @@
+# cmd/srv9p/CMakeLists.txt - Build script for srv9p test/dev executable
+#
+# Copyright (C) 2024 Luke T. Shumaker <lukeshu@lukeshu.com>
+# SPDX-Licence-Identifier: AGPL-3.0-or-later
+
+add_executable(srv9p
+ main.c
+)
+target_include_directories(srv9p PUBLIC ${CMAKE_CURRENT_SOURCE_DIR}/config)
+target_link_libraries(srv9p
+ libcr
+ libcr_ipc
+ libnetio
+ lib9p
+)