summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 9 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 100214c..c9774c6 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -16,7 +16,15 @@ project(sbc_harness)
pico_sdk_init()
-add_compile_options(-Wall -Wextra -Werror)
+add_compile_options(-Wall -Wextra -Wswitch-enum -Werror)
+
+function(_suppress_tinyusb_warnings)
+ __suppress_tinyusb_warnings()
+ set_source_files_properties(
+ ${PICO_TINYUSB_PATH}/src/device/usbd.c
+ PROPERTIES
+ COMPILE_OPTIONS "-Wno-switch-enum")
+endfunction()
function(target_embed_sources arg_target arg_hdrname)
set(embed_objs)