summaryrefslogtreecommitdiff
path: root/libcr_ipc/CMakeLists.txt
diff options
context:
space:
mode:
authorLuke T. Shumaker <lukeshu@lukeshu.com>2025-04-07 14:28:17 -0600
committerLuke T. Shumaker <lukeshu@lukeshu.com>2025-04-07 20:28:56 -0600
commita1a20d71f6d9f6b26893b0f2d641da47cd59e74e (patch)
treed6a692b3858f2c222dd8eeed371bf7ed4ec27db7 /libcr_ipc/CMakeLists.txt
parent4d5a8b2f99be5e04954c5067080d1725af8c0ae7 (diff)
libcr_ipc: Add waitgrouplukeshu/waitgroup
Diffstat (limited to 'libcr_ipc/CMakeLists.txt')
-rw-r--r--libcr_ipc/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/libcr_ipc/CMakeLists.txt b/libcr_ipc/CMakeLists.txt
index 7d249d7..1f0ad07 100644
--- a/libcr_ipc/CMakeLists.txt
+++ b/libcr_ipc/CMakeLists.txt
@@ -11,6 +11,7 @@ target_sources(libcr_ipc INTERFACE
mutex.c
rpc.c
sema.c
+ waitgroup.c
)
target_link_libraries(libcr_ipc INTERFACE
libcr
@@ -23,6 +24,7 @@ set(ipc_tests
rpc
select
sema
+ waitgroup
)
foreach(test IN LISTS ipc_tests)
add_lib_test(libcr_ipc "test_${test}")