summaryrefslogtreecommitdiff
path: root/libcr/CMakeLists.txt
diff options
context:
space:
mode:
authorLuke T. Shumaker <lukeshu@lukeshu.com>2024-09-30 14:55:35 -0600
committerLuke T. Shumaker <lukeshu@lukeshu.com>2024-09-30 14:55:35 -0600
commitd16d8bfeb1766c339da797eb2de3126e63a5a44c (patch)
treec1bc0c050ab27465a31ee0278fde031df07802af /libcr/CMakeLists.txt
parentd82d7f59f9227a0ea33d13af3c7ed95e16fdd2e3 (diff)
make coroutine.c signal-safe, add cr_cid_info()
Diffstat (limited to 'libcr/CMakeLists.txt')
-rw-r--r--libcr/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/libcr/CMakeLists.txt b/libcr/CMakeLists.txt
index 14acba6..92a290a 100644
--- a/libcr/CMakeLists.txt
+++ b/libcr/CMakeLists.txt
@@ -8,3 +8,6 @@ target_include_directories(libcr SYSTEM INTERFACE ${CMAKE_CURRENT_LIST_DIR}/incl
target_sources(libcr INTERFACE
coroutine.c
)
+target_compile_options(libcr INTERFACE
+ -fno-split-stack
+)