summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorLuke T. Shumaker <lukeshu@lukeshu.com>2024-09-15 23:16:00 -0600
committerLuke T. Shumaker <lukeshu@lukeshu.com>2024-09-15 23:16:00 -0600
commit7c30fe0be98a3028964d437f5c31cc968fbf9755 (patch)
tree36047161fe75349acac0e179b8010205a7fe08bb /CMakeLists.txt
parentd297d8ec1f5bac1015c53dfe169d2ce1a838b007 (diff)
wip
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt20
1 files changed, 12 insertions, 8 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ad5fba9..f229d17 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -7,11 +7,15 @@ project(sbc_harness)
pico_sdk_init()
-add_executable(hello_world hello_world.c)
-target_link_libraries(hello_world pico_stdlib)
-pico_enable_stdio_usb(hello_world 1)
-pico_enable_stdio_uart(hello_world 0)
-pico_enable_stdio_semihosting(hello_world 0)
-pico_enable_stdio_rtt(hello_world 0)
-pico_add_extra_outputs(hello_world) # create map/bin/hex/uf2 file in addition to ELF.
-pico_set_program_url(hello_world "https://git.lukeshu.com/sbc-harness")
+add_executable(sbc_harness)
+target_sources(sbc_harness PUBLIC
+ main.c
+)
+target_include_directories(sbc_harness PUBLIC ${CMAKE_CURRENT_LIST_DIR}) # So TinyUSB can find tusb_config.h
+target_link_libraries(sbc_harness pico_stdlib)
+pico_enable_stdio_usb(sbc_harness 0)
+pico_enable_stdio_uart(sbc_harness 1)
+pico_enable_stdio_semihosting(sbc_harness 0)
+pico_enable_stdio_rtt(sbc_harness 0)
+pico_add_extra_outputs(sbc_harness) # create map/bin/hex/uf2 file in addition to ELF.
+pico_set_program_url(sbc_harness "https://git.lukeshu.com/sbc-harness")