summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorLuke T. Shumaker <lukeshu@lukeshu.com>2024-09-13 21:54:37 -0600
committerLuke T. Shumaker <lukeshu@lukeshu.com>2024-09-13 21:54:37 -0600
commit41c688316889ac2edddfae09fbeaa52a2206a33c (patch)
tree27b63116e43690b11caf752c6d9a42cb2e978910 /CMakeLists.txt
initial commit
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..d9c005d
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,13 @@
+cmake_minimum_required(VERSION 3.13)
+
+set(PICO_SDK_PATH "${CMAKE_SOURCE_DIR}/3rd-party/pico-sdk")
+include(pico_sdk_import.cmake)
+
+project(sbc_harness)
+
+pico_sdk_init()
+
+add_executable(hello_world hello_world.c)
+target_link_libraries(hello_world pico_stdlib)
+# create map/bin/hex/uf2 file in addition to ELF.
+pico_add_extra_outputs(hello_world)